How to fix driver conflicts with your Redragon mechanical keyboard on Windows 10.

Solution: Redragon Mechanical Keyboard Not Working with Windows 10

I recently bought the new RGB version of the popular Redragon USAS K553 mechanical keyboard for testing and review purposes (look for that in a couple weeks). I connected it to my Windows 10 machine and watched as the LED lights went through a “boot up” pattern. I opened up Firefox and tried typing a URL. Nothing happened. I pressed down the Windows key. Nothing. Uh-oh. Not a single key on the keyboard would input a character once pressed. Was my shiny new mech dead on arrival? Read on to find out.

Trouble in RGB Paradise

The first attempt I made to fix the board was unplugging it from the USB port and trying the one next to it. Again, no response. Same story with all my other USB ports. Keep in mind this mechanical keyboard doesn’t come with any software and Redragon advertises it as “Plug & Play” with no need to install drivers.

Restarting my PC was of no help. At least the LED backlighting was working, so it was receiving power. Just no communications. At this point I was becoming really agitated and started to suspect Windows 10 was the cause of my frustrations.

Let’s try another device that doesn’t run on the Windows platform. I pulled out my Samsung Galaxy S6 and connected the Redragon using an OTG adapter cable. It worked perfectly on Android. Whew. So now I knew their was nothing physically wrong with the keyboard. This was a driver issue with Windows 10.

How I Fixed It

After a bit of research and Google searching I found the solution to my problem. If you have a Redragon mechanical keyboard that powers on but isn’t responding to any input, try these steps first before returning it for a refund or exchanging for a board of the same model that will most likely still suffer from the issue.

Note: It would be helpful to have a second working keyboard also plugged in during these steps.

1. Navigate to the Device Manager with your Redragon mechanical keyboard still plugged in. Start typing “Device Manager” in the Windows search. Click on Device Manager once it shows up. If you don’t have a second keyboard to type with it can also be accessed by right-clicking the start button and selecting Device Manager from the menu that pops up.

Open Device Manager

2. Once in the Device Manager, scroll down and find “Universal Serial Bus controllers” and click on the arrow to the left to expand the list.

3. From this list locate “ND-tech USB Adapter”, right-click it and select “Update Driver Software…” from the menu box.

Right-click "ND-tech USB Adapter"

4. Choose to manually select your driver by clicking on “Browse my computer for driver software”.

Manually browse for drivers

5. Now choose “Let me pick from a list of device drivers on my computer”.

Let me pick from list of drivers.

6. To complete the driver update process, select “USB Composite Device” under Model and click Next.

Select "USB Composite Device".

You should now be presented with a screen letting you know Windows 10 has successfully updated the drivers for your device.

Successfully updated Windows 10 drivers for Redragon mechanical keyboard.

Close this screen, go back to the Device Manager and expand “Keyboards”. There should be multiple entries for “HID Keyboard Device”.

Once you have completed those steps, test your Redragon mechanical keyboard with a program called Aqua Key Test and confirm that all the keys and functions are working properly. Hopefully that solved your issues and saved you from a lot of frustration and wasted time. If not, leave a comment below describing the problems you’re still experiencing.


  • I just wanted to let you know how incredibly helpful this was. I’m typing on my Red Dragon as we speak because you helped! Thanks so much!

  • Thank you so much! I have a Redragon Vara (Love it!) and it was working on my old machine and i plug it into my new machine (i7 7700k :P) and nothing, nothing happened so i was a little bit stressed but i know it was Windows because it was working before, a google search found me this page and you helped me out, thank you so much!

  • Will this fix still work if I use a PS2 to USB adapter? I don’t have enough USB slots so I’ll probably have to use that.

    • It may not even have problems over PS/2 since the main issue is caused by the default USB drivers. I only ever tried it over USB. When I get a chance I’ll test it with a PS/2 adapter.

  • Thank you so much! Just switched to Win10 and had this issue only with my Redragon mech. My KB was fine, this solved it for me.

  • Just got a new Red Dragon keyboard and this was the same issue I was having. Thank you so much for the fix! Worked perfectly!

  • May I ask, I have made my Redragon Kumara, a custom RGB profile. It works well, untill you shut the computer off, it doesn’t turn on the RGB profile automatically you have to click fn+end again which is frustrating as you always have to turn it on everytime. Does yours do this?

  • I have a vara k551 keyboard and I am also having this issue. But when I go to device manager, and then open up “Universal Serial Bus Controllers” There is no option for “ND-Tech USB Adapter”. I cannot find a solution for this problem now. Any help would be greatly appreciated, I just got this keyboard

  • OMG YOU SAVED MY KEYBOARD!!! I was so frustrated because it all of a sudden stopped working but now its fixed. YOU DA BEST!!!

  • You’re a life saver! Thank you so very much for taking the time to post this solution. A dead keyboard is now clackety clacking away again.

      • I just had this issue .. without the nd showing up in device manager … windows 10 I typed in the search box troubleshoot navigated to hardware… did a scan it found an issue with the usb cause the keyboard was plugged in … it went through about 3 mins of fixing had to reboot and the keyboard a k 522 started working … hope this helps

  • My redragon vara was working previously and suddenly today it doesn’t work and when i plugged it in. Even my laptop keyboard is not working

  • Yet again, a random article from years ago saves me from my tech problems.

    Thanks a ton! Saved me after Windows update wrecked my drivers.

  • Press Fn+ macro recording button (it has an icon of a circle in circle) simultanuously and for a few seconds until whole keyboard starts blinking. This resets the keyboard (you will lose your macros). That helped for me.

    I came here after my son did something to brand new keyboard RedDragon Asura K501.
    The solution above did not work as no NDF-tech or any other non-standard adapter was present on my machines and keyboard was lit but not responding on two different machines with Windows 10, all USB ports.

    • Resetting the keyboard worked for my K596. Thank you for the suggestion. I spent all morning trying all the other options on these forums trying to fix it.

  • Hi! I tried this and it didnt work 😭 i have the redragon s102-1. It worked before but then suddenly it stopped working. The ND-tech usb adapter is not showing when i click on the universal. I am so frustrated. I really hate redragon now

  • Hi! i want to do this method but the problem is that i dont see any ND-tech usb adapter under the universal. i only see Unknown USB Device (Device Descriptor Request Failed). My keyboard is k552 anyone can help me? i just bought it.

  • I have a problem where my keyboard works but my ctrl,windows key, and alt on the left side arent working at all they don’t respond or anything but on the right side of my reddragon k350 (white) keyboard the ctrl shortcuts are there and I have no idea what to do to fix this idk if I somehow broke my keyboard or what

  • My son and I are trying to get his S101-3 keyboard mouse to work. I do not show ND-tech USB Adapter. I do however see a caution ! next to “Unknown USB Device (Device Descriptor Request Failed). When I browse my computer for driver software I see “Unknown USB Device (Device Descriptor Request Failed)”. I am able to find “USB Composite Device” only when de-selecting “Show Compatible hardware”. I have attempted to update both the compatible “Unknown USB Device (Device Descriptor Request failed)” and the non-compatible “USB Composite Device” to no avail. When I navigate to the HID Keyboard Device the status states, “This device is working properly.” on both HID keyboard Device options.

  • Mine lights up and everything but the enter button won’t work idk why and I have tried everything

  • for anyone that may still need help with the keyboard or for the future it could be an even more simple fix than this I bought a K530 and i was confused as it wasnt working but i was being dumb if you plug it in you dont need to have the on switch on as that is for Bluetooth.If you keep it plugged in you dont need the drivers either but if you want to use it bluetooth download the drivers for the right keyboard off the reddragon site

  • Hey..I have the K552 and I it’s not working at all, like no RGB + not working, I have almost tried everything on the internet I could find, Please help me, I build my setup like a 3 days ago now I am facing this issue!
    Please save me🙏

    • I made it,
      My keyboard stopped working when i download the redragon software and running firmware updater, to solve it i opened the application again and select bootloader option, addicionally i open the main software and it works fine

Leave a Reply

Your email address will not be published.